调整图像大小、裁切和校正图像

你可以裁切图像来改善构图或去除不需要的部分。裁切时,可使用预设或自定的长宽比,也可将图像限制为原始长宽比。还可以校正因无意间倾斜拍摄而产生歪斜或透视失真的图像。

裁切和校正图像#

  1. 通过以下任一方式选择裁切工具:
    • 在 Pixelmator Pro 工具边栏中选择裁切
    • 从屏幕顶部的工具菜单中选取 工具 > 裁切
    • 按键盘上的 C 键。
  2. 拖移裁切框控制柄来调整裁切框大小,选择要保留的图像区域;也可在宽度和高度栏位输入自定大小,或使用文本栏位计算计算大小。

    若要将裁切框限制为某个长宽比,请点按“限制”弹出式菜单,然后从可用预设中选取。

  3. 若要校正图像,请拖移裁切框外的任意位置、拖移“工具选项”面板中的旋转滑块,或点按旋转滑块两端的旋转按钮。也可在“角度”栏位输入特定角度。

若要快速将裁切框重设为原始图像高度、让图像适合裁切框、在受限裁切和自由裁切之间切换,或自动完成其他裁切和校正任务,可使用键盘快捷键。完整的裁切工具快捷键列表请参阅 Pixelmator Pro 键盘快捷键

将裁切框限制为自定长宽比或大小#

  1. 通过以下任一方式选择裁切工具:
    • 在 Pixelmator Pro 工具边栏中选择裁切
    • 从屏幕顶部的图像菜单中选取 图像 > 裁切
    • 按键盘上的 C 键。
  2. 如果已选择裁切预设,请点按“限制”弹出式菜单,然后选取“自定长宽比”或“自定大小”。
  3. 在“工具选项”面板的指定栏位中输入新的裁切比例或大小。

选择隐藏或删除图像的裁切区域#

裁切时,可以选择隐藏或删除图像中被裁切的内容。

  1. 通过以下任一方式选择裁切工具:
    • 在 Pixelmator Pro 工具边栏中选择裁切
    • 从屏幕顶部的图像菜单中选取 图像 > 裁切
    • 按键盘上的 C 键。
  2. 选择“删除裁切像素”可永久删除图像的裁切区域;取消选择则可进行非破坏性裁切,改为隐藏图像的裁切区域。

自动裁切图像#

可使用由机器学习驱动的 ML 裁切自动裁切图像。ML 裁切会利用机器学习预测所选长宽比的最佳裁切方式。

  1. 通过以下任一方式选择裁切工具:
    • 在 Pixelmator Pro 工具边栏中选择裁切
    • 从屏幕顶部的图像菜单中选取 图像 > 裁切
    • 按键盘上的 C 键。
  2. 点按“工具选项”面板中的“ML 裁切”。按钮会亮起黄色,表示 ML 裁切已用于该图像。

启用 ML 裁切后,可浏览可用的裁切预设,以查看基于特定裁切长宽比给出的其他裁切建议。

自动校正图像#

如果想自动校正图像,可使用“自动校正”功能。“自动校正”会自动找出图像中的地平线并据此校正图像。

若要自动校正图像:

  1. 通过以下任一方式选择裁切工具:
    • 在 Pixelmator Pro 工具边栏中选择裁切
    • 从屏幕顶部的图像菜单中选取 图像 > 裁切
    • 按键盘上的 C 键。
  2. 点按“工具选项”面板中 ML 裁切按钮旁的更多 ,然后选取“自动校正”。

记住上次使用的裁切长宽比#

在某些工作流程中,重新应用上次使用的裁切比例会很有用。可按以下步骤让 Pixelmator Pro 记住此设置:

  1. 通过以下任一方式选择裁切工具:
    • 在 Pixelmator Pro 工具边栏中选择裁切
    • 从屏幕顶部的图像菜单中选取 图像 > 裁切
    • 按键盘上的 C 键。
  2. 点按“工具选项”面板顶部的“限制”弹出式菜单。
  3. 选择希望 Pixelmator Pro 如何记住上次使用的长宽比:
    • 始终:跨不同文稿和不同编辑阶段记住上次使用的长宽比。
    • 当前文稿:只为特定文稿记住上次使用的长宽比。打开或创建新文稿时,裁切比例会默认设为“自定大小”。
    • 从不:切换工具、打开其他文稿或开始新的编辑阶段时,不会记住上次使用的长宽比。

选取裁切叠加层#

裁切图像时,可以使用摄影和图像编辑中常用的裁切辅助线。可从七种不同辅助线中选择;虽然你始终可以按自己的方式裁切图像,裁切辅助线可提供观察图像的新角度,或帮助获得更醒目、平衡的构图。

  1. 通过以下任一方式选择裁切工具:
    • 在 Pixelmator Pro 工具边栏中选择裁切
    • 从屏幕顶部的图像菜单中选取 图像 > 裁切
    • 按键盘上的 C 键。
  2. 点按“叠加层”弹出式菜单,然后选取想要的辅助线。
    • 三分法:添加由九个矩形构成的网格。通常,图像的焦点对象会放在两条中线或矩形线的交叉点。例如,人眼查看图像时会自然移向右上交叉点,因此若图像中有想吸引注意的对象,可将其放在该处。
    • 网格:为图像添加简单网格。校正图像时,可借此更精确地调整水平和垂直线条。
    • 对角线:与三分法叠加层相似,对角线叠加层最适合裁切透视感明显的图像,也就是可以轻易画出从焦点对象延伸出去或朝向焦点对象的对角线的图像。
    • 三角形:此叠加层可改善具有不均衡对角线的图像构图。焦点对象可放在三角形顶点,或沿叠加层的对角线排列。
    • 黄金比例:类似三分法,但更聚焦于中心。可用来将景致或对象带入照片的视线范围。
    • 黄金螺旋:可用来平衡带有曲线或延伸线条的图像,焦点位于螺旋中心。
    • 中心:可使用中心叠加层来获得对称效果,或确认图像中的垂直线或水平线是否正好穿过图像中心。

若要改变黄金螺旋或三角形裁切叠加层的方向,请按键盘上的 Shift ⇧ + Command ⌘ + G

若要循环切换裁切叠加层,请按键盘上的 Command ⌘ + G

显示或隐藏裁切叠加层#

在“叠加层”弹出式菜单中,也可选取裁切叠加层的显示时机:

  • 自动显示叠加层:仅在拖移裁切框控制柄时显示叠加层。
  • 始终显示叠加层:每次启用裁切工具时,都会显示所选或上次使用的叠加层。
  • 从不显示叠加层:完全关闭叠加层。