从 Photos 编辑
你可以从 Photos app 打开图像,在 Pixelmator Pro 中编辑,然后将更改存回资料库中的原始图像。
在 Pixelmator Pro 中从 Photos 打开图像#
使用此方法存储图像时,可保留所有图层(layers)、调整(adjustments)、效果(effects)、样式和其他格式设置。
- 若要从 Photos 打开图像,请执行以下任一操作:
- 在 Pixelmator Pro 欢迎屏幕中选取 Open the Photos Browser。
- 选取 File > New From Photos,选择要编辑的图像,然后点按 Open。
- 编辑图像。
- 从屏幕顶部的 File 菜单中选取 File > Modify Original in Photos 以存储更改。
- 已创建附属文件(sidecar file)。现在可以关闭并删除文稿。
此外,你可以关闭“For Images Opened from Photos”,以不保留编辑内容并用 Pixelmator Pro 所作编辑覆盖原始图像。编辑后的图像始终可以在 Photos 中使用 Image > Revert to Original 还原为原始图像。
从 Photos 发送图像以在 Pixelmator Pro 中编辑#
使用此方法会以更改覆盖原始图像,并合并所有图层、调整、效果、样式和其他格式设置。
- 打开 Photos app。
- 找到要编辑的图像并点按以选中。
- 执行以下任一操作:
- 从屏幕顶部的 Image 菜单中选取 Image > Edit With > Pixelmator Pro。
- 按住
Control ⌃点按照片,然后选取 Edit With > Pixelmator Pro。
- 编辑图像。
- 从屏幕顶部的 File 菜单中选取 File > Save 以存储更改。
- 更改已存储到 Photos 资料库。现在可以关闭并删除文稿。

如果你已在 Mac 上创建项目,并希望连同全部无损编辑(nondestructive edits)内容和图层一起移至 Photos,请参阅使用 Pixelmator Pro Photos 扩展功能文章,了解如何将 Pixelmator Pro 文稿导入 Photos。