添加效果

使用效果(effects),可以用多种不同方式彻底改变图像、形状和文字的外观。所有 Pixelmator Pro 效果均可在效果浏览器(Effects Browser)中找到;你可以按名称搜索,或浏览将相似或相关效果归在一起的类别,例如模糊(Blur)、平铺(Tile)和风格化(Stylize)。例如,模糊类别包含 Gaussian、Box、Disc、Motion、Zoom、Spin、Bokeh、Tilt-Shift 和 Focus 模糊效果。

Pixelmator Pro 的效果均为无损编辑(nondestructive),因此可以对图形应用任意数量的效果,并将它们组合成自己的艺术或特殊效果。预设功能可让你保存效果组合,在任何图像中重复使用,甚至与其他 Pixelmator Pro 用户共享。

开启或关闭效果#

你可以直接将效果应用到图层,也可以把它们添加为效果图层(effect layers)。直接添加效果会自动将它与所应用的图层关联。这意味着编辑时,对图层所作的改动也会影响效果,反之亦然。例如,若尝试在应用某些扭曲(Distortion)效果的图层上绘画,画笔笔触也会带有相同的扭曲。

  1. 通过以下任一方式选择效果工具(Effects):
    • 在工具边栏中选择效果
    • 从屏幕顶部的工具菜单中选取 工具 > 效果
    • 按键盘上的 F 键。
  2. 选择想编辑的一个或多个图层。
  3. 开启或关闭想要的效果旁的开关。若未显示任何效果,请点按 添加效果,再从效果浏览器中选取效果。

请注意,效果只会显示在应用它的图层或图层组上。若想将效果添加到合成图像中的多个图层,请创建效果图层。

添加效果图层#

效果图层是可添加到项目中的独立元素,并且可与所应用的图层单独编辑。和对单个图层应用效果一样,创建效果图层也能让你完全以无损方式工作。效果图层可在图层列表中自由上移或下移,并会改变其下方所有其他图层的外观。除此之外,所有效果控制项的工作方式都和直接编辑图层时相同。

通过以下任一方式添加效果图层:

  • 从屏幕顶部的插入菜单中选取 插入 > 效果
  • 点按效果面板顶部的添加
  • 点按图层边栏顶部的插入图层 ,然后选择效果。
  • 点按工具栏中的添加图层 ,然后选择效果。
  • 按键盘上的 Shift ⇧ + Command ⌘ + F

重新排列效果顺序#

若对单个图层应用两个或更多效果,可以重新排列它们的组合顺序。例如,若应用 Gaussian 模糊效果和 Kaleidoscope 效果,将 Gaussian 效果置于顶部表示先平铺原始图层,再模糊结果。

要重新排列效果,请点按并将效果向上或向下拖移到效果列表中。

将效果从一个图层复制到另一个图层#

将同一效果应用到多个图层的快速方法是使用效果预设。不过,也可以通过复制将同一效果应用到多个图层。

  1. 选择含有要复制效果的图层。
  2. 通过以下任一方式复制效果:
    • 从屏幕顶部的格式菜单中选取 格式 > 效果 > 拷贝效果
    • 在图层边栏中,Control ⌃ – 点按要从中复制效果的图层,然后选取 效果 > 拷贝效果
  3. 选择要应用所复制效果的图层。
  4. 通过以下任一方式粘贴效果:
    • 从屏幕顶部的格式菜单中选取 格式 > 效果 > 粘贴效果
    • 在图层边栏中,Control ⌃ – 点按要向其粘贴效果的图层,然后选取 效果 > 粘贴效果

重设应用到图层的所有效果#

通过以下任一方式操作:

  • 在图层边栏中,Control ⌃ – 点按图层,然后选取 效果 > 重设效果
  • 选取 工具 > 效果,然后点按工具选项面板底部的重设效果按钮。

扁平化效果#

当你满意某个图层的外观,并想调整其大小而不让效果在图层边缘之外重复时,扁平化应用到图层的全部效果会很有用(例如平铺效果就会发生这种重复)。

通过以下任一方式操作:

  • 在图层边栏中,Control ⌃ – 点按图层,然后选取 效果 > 扁平化效果
  • 选取 格式 > 效果 > 扁平化效果
  • Option ⌥ – 点按工具选项面板底部的重设按钮。

暂时查看未应用任何效果的原始图层#

编辑效果时,可以快速比较图像在应用效果前后的外观。

可通过以下几种方式进行比较或开启分屏比较视图:

  1. 在图层边栏中点按,选择想查看其未应用任何效果外观的图层。
  2. 通过以下任一方式操作:
    • 按住工具选项面板底部的显示原图按钮,或按键盘上的 Control ⌃ + M
    • Option ⌥ – 点按工具选项面板底部的显示原图按钮。
    • 按键盘上的 Control ⌃ + C
    • 若使用触控板,请用力点按画布,或双指轻点画布并选取分屏比较。

移除效果#

  1. 在图层边栏中点按,选择含有不需要效果的图层。
  2. 点按要移除效果旁的移除