调整选区

创建选区后,可以通过多种方式调整它,例如移动选区轮廓、向选区添加或从中减去区域,或者调整其大小。

移动选区轮廓#

如果已经有选区,并且想更改图像的另一部分,可以创建新选区,或将现有选区移到想调整的区域。

若要移动选区轮廓:

  1. 有活动选区时,选择任一选区工具。
  2. 在工具选项面板中选择新建选区模式。或者,按住 Control ⌃ 点按选区内部,然后选取 Transform Selection。
  3. 将鼠标指针移到选区轮廓内部并拖移。

更改选区的形状或大小#

  1. 创建选区。
  2. 拖移选区控制柄以更改选区的形状或大小。

反转选区#

反转选区会取消选择图像中所有已选部分,反之亦然。若要反转选区,请执行以下任一操作:

  • 选取 Edit > Invert Selection
  • 选择选区工具,然后点按工具选项面板底部的 Invert 按钮。
  • 选择选区工具,然后按住 Control ⌃ 点按图像任意位置,并从快捷菜单中选取 Invert Selection。
  • 按键盘上的 Shift ⇧ + Command ⌘ + I

取消选择选区#

若要取消选择画布上的任何活动选区,请执行以下任一操作:

  • 从屏幕顶部的“编辑”菜单中选取 Edit > Deselect
  • 按键盘上的 Command ⌘ + D

更改选区模式#

添加到现有选区#

向选区添加会将新选择的任何区域添加到现有选区。

若要添加到现有选区,请执行以下任一操作:

  • 在工具选项面板中将选区模式更改为 Add。
  • 开始选择前按住 Shift ⇧

若要在绘制选区时查看尺寸信息,请确保已在 Pixelmator Pro 设置中打开信息标签。

从现有选区减去#

从选区减去会取消选择绘制过的区域,并保留现有选区的其余部分。

若要从现有选区减去,请执行以下任一操作:

  • 在工具选项面板中将选区模式更改为 Subtract。
  • 开始选择前按住 Option ⌥

将一个选区与另一个相交#

使用 Intersect 选区模式时,绘制过的当前已选区域会被保留,位于新选区外的当前已选区域会从选区中移除。

若要与现有选区相交,请执行以下任一操作:

  • 在工具选项面板中将选区模式更改为 Intersect。
  • 开始选择前按住 Shift ⇧Option ⌥

隐藏选区控制柄#

隐藏选区控制柄有助于避免意外调整选区大小。

  1. 选择任一选区工具。
  2. 按住 Control ⌃ 点按图像,然后在快捷菜单中取消选择 Show Selection Handles。