细化选区

创建选区后,可以使用选择并遮住工具(Select and Mask tool)中的选项来优化它:向现有选区添加或减去区域,调整柔和度、圆度或大小,或使用智能细化工具。细化选区后,还可以选择如何处理它:将由选区创建的蒙版添加到同一图层或重复图层、创建包含选区内容的新图层,或仅将其保留为选区。

打开选择并遮住工具#

  1. 创建选区。
  2. 执行以下任一操作:
    • 激活任一选区工具后,点按工具选项面板中的 Select and Mask 按钮。
    • 从屏幕顶部的“编辑”菜单中选取 Edit > Select and Mask
    • 从屏幕顶部的“工具”菜单中选取 Tools > Select > Select and Mask
    • 按键盘上的 Option ⌥ + Command ⌘ + R

手动细化选区#

  1. 调整工具选项面板中的选项:
    • 形状圆度: 调整选区轮廓圆化的程度。
    • 边缘柔和度: 调整选区轮廓边缘柔化的程度。边缘越柔和,复制或编辑已选区域时,它通常越能与图像的其他部分融合。
    • 扩展: 更改选区大小。
  2. 在 Output 弹出式菜单中选择细化选区的处理方式:
    • 选区: 将细化后的选区应用到图层。
    • 蒙版: 将由细化选区创建的蒙版应用到活动图层。
    • 带蒙版的新图层: 创建活动图层的副本,并应用由细化选区创建的蒙版。
    • 新图层: 使用细化选区的内容创建新图层。Pixelmator Pro 会自动净化选区边缘,移除前一背景遗留的任何颜色。
  3. 点按工具选项面板底部的 Apply,将细化结果应用到选区。

使用智能细化自动细化选区#

智能细化(Smart Refine)使用基于机器学习的算法,智能检测选区边缘的头发或毛皮等精细细节,并自动细化选区轮廓。若要使用智能细化:

  1. 创建选区。
  2. 执行以下任一操作:
    • 从屏幕顶部的“编辑”菜单中选取 Edit > Smart Refine
    • 选取 Edit > Select and Mask,然后在工具选项面板中点按 Smart Refine。
    • 按键盘上的 Option ⌥ + Command ⌘ + R
  3. 点按工具选项面板底部的 Apply,将细化结果应用到选区。

向现有选区添加或从中减去区域#

Select and Mask 工具处于活动状态时,可以使用选区细化画笔在图像区域上绘制,快速编辑选区。

  1. 选择要使用的画笔类型:
    • 细化边缘画笔: 只在选区边缘添加或减去。
    • 快速选择画笔: 如同使用快速选择工具一样,向选区添加或从中减去。
    • 基本画笔: 如同使用基本画笔绘画一样,向选区添加或从中减去。
  2. 选择选区模式:
    • 添加选区模式处于活动状态时,在其上绘制的任何区域都会添加到选区(并失去彩色叠加层)。
    • 选择减去选区模式后,在其上绘制的区域会从选区中移除(并会被彩色叠加层覆盖)。
  3. 调整画笔的大小和柔和度。
  4. 在想添加到选区或从中减去的图像区域上绘制。