将设计切分为单独图像

“切片”工具可将设计分成多张单独图像,再以各自的优化设置分别导出。当你处理网页设计或界面设计时,这项功能很有用,例如,你可能需要将按钮导出为一种格式,而将照片图像或标志导出为另一种格式。

在 Pixelmator Pro 中,你可以从图像内的图层或图层组创建切片,也可以手动绘制。每个切片均会按你选择的设置优化,并在图像中各自显示优化后的预览。

手动绘制切片#

  1. 用以下任一方式选择“切片”工具:
    • 在 Pixelmator Pro 工具栏中点按“切片”,或从“工具”边栏选择它。
    • 在 Pixelmator Pro 工具栏中点按“共享”,然后选取“为网页导出”。
    • 从屏幕顶部的“文件”菜单中选取 “文件”>“为网页导出”
    • 从屏幕顶部的“工具”菜单中选取 “工具”>“为网页导出”
    • 按键盘上的 KShift ⇧ + Command ⌘ + E
  2. 在要导出的图像区域上拖移。

从图层或图层组创建切片#

执行以下任一操作:

  • 在“图层”边栏中拖移图层或图层组,并将其放到“工具选项”窗格的切片列表中。
  • 在“图层”边栏中,按住 Control ⌃ 点按图层或图层组,然后选取“添加以供导出”。

从切片之间的剩余区域创建切片#

创建切片时,落在切片外的图像区域可提升为切片。要从切片之间的剩余区域创建切片:

  • 选中“切片”工具后,按住 Control ⌃ 点按要提升为切片的图像区域,然后选取“提升为切片”。

重命名切片#

默认情况下,手动绘制的切片会依次命名为“切片 1”“切片 2”“切片 3”等;从图层创建的切片则按图层名称命名。你可以重命名图像中的任意切片。

  • 选中“切片”工具后,在“工具选项”窗格中双击或用力点按切片名称,然后输入新名称。

选择一个或多个切片#

  • 选中“切片”工具后,点按图像中的切片。要选择多个切片,请在点按时按住 Shift ⇧ 键。

调整切片大小#

  • 选中“切片”工具后,拖移切片边缘任一黑色图层控制柄。

移动切片#

  • 将“切片”工具指针移到切片内,然后拖移以移动它。

更改切片的堆叠顺序#

切片的堆叠顺序会显示在“工具选项”窗格中。其顺序不会改变导出的图像,但最上层切片会显示优化后的预览。将切片移到前方也更便于选取和移动。如果一个切片的一部分位于另一个切片之后,实线轮廓会变为虚线。

选中“切片”工具后,可用以下任一方式更改堆叠顺序:

  • 选择一个或多个切片,再在切片列表中拖移以重新排列。
  • 选择一个或多个切片,按住 Control ⌃ 点按画布,然后选取“移到最前”“前移”“移到最后”或“后移”。

更改切片的优化设置#

  1. 点按以选择一个或多个切片。
  2. 添加一个或多个导出格式并进行自定。

    若要进一步了解如何为网页优化图像(包括切片),请参阅为网页导出图像或视频

隐藏或显示优化后的预览#

“切片”工具处于活跃状态时,图像中的每个切片都会显示其优化设置,以便你准确查看导出图像的外观。大多数时候你不会看出明显差异;不过,如果大幅降低切片的质量或颜色数量,可能开始看到视觉变化。

  • 要隐藏或显示优化后的预览,请按住 Control ⌃ 点按图像中的任意位置,然后选择或取消选择“显示优化后的预览”选项。

删除切片#

点按以选择一个或多个切片,然后执行以下任一操作:

  • 按键盘上的 Backspace ⌫ 键。
  • 在“工具选项”窗格中,按住 Control ⌃ 点按切片列表中已选的切片,然后选取“删除”。
  • 按住 Control ⌃ 点按图像中的切片,然后选取“删除切片”。

删除所有切片#

  • 选中“切片”工具后,按住 Control ⌃ 点按图像区域,然后选取“清除切片”。

导出单个切片#

  1. 选中“切片”工具后,点按以选择一个或多个切片。
  2. 执行以下任一操作:
    • 将选中的切片拖放到桌面或 Finder 窗口中。
    • 按住 Control ⌃ 点按画布上的切片,选取“导出切片”,选择位置,然后点按“导出”。
    • 按住 Control ⌃ 点按“工具选项”窗格中的切片,选取“导出”,选择位置,然后点按“导出”。

导出所有切片#

  1. 选中“切片”工具后,执行以下任一操作:
    • 点按“工具选项”窗格底部的“导出”。
    • 在“工具选项”窗格中,按住 Control ⌃ 点按切片列表中的切片,然后选取“全部导出”。
  2. 选择位置,然后点按“导出”。