应用生成器效果

生成器(Generator)类别中的效果会在所选图层上生成各种对象和几何图案。

使用颜色、渐变、图案或图像填充图像#

生成器效果可直接应用到单个图层,也可通过效果图层应用到合成图像中的多个图层。

  1. 选择想编辑的一个或多个图层。
  2. 通过以下任一方式操作:


    将效果应用到当前选中的图层:

    • 在工具边栏中点按效果 ,点按添加效果,然后从生成器集合中选择效果。
    • 选取 格式 > 效果 > 生成器,再选取效果。
    • 按键盘上的 F,点按添加效果,然后从生成器集合中选择效果。

    将效果应用到多个图层:

    • 从屏幕顶部的插入菜单中选取 插入 > 效果,点按添加效果,然后从生成器集合中选择效果。
    • 点按图层边栏顶部的插入图层 ,选择效果,点按添加效果,然后从生成器集合中选择效果。
    • 按键盘上的 Shift ⇧ + Command ⌘ + F,点按添加效果,然后从生成器集合中选择效果。

应用 Checkerboard 效果#

Checkerboard 效果会使用棋盘图案填充所选图层。

自定效果:

  • 点按 颜色 1 颜色框,为棋盘上一组方块选择颜色。也可以按住键盘上的 Option ⌥ 键,快速从图像中拾取颜色。
  • 点按 颜色 2 颜色框,为棋盘上另一组方块选择颜色。也可以按住键盘上的 Option ⌥ 键,快速从图像中拾取颜色。
  • 移动 宽度 滑块以调整图案中方块大小。也可以输入 0.0 px 到 800.0 px 之间的值。
  • 移动 锐度 滑块以调整方块的锐利度。也可以输入 0% 到 100% 之间的值。
  • 移动 不透明度 滑块以调整图案透明度。点按 Opacity (Normal) 弹出式菜单,以选择不同的混合模式。
  • 移动效果绳索的控制柄以调整棋盘位置。若未显示效果绳索,请点按工具选项面板中的绳索按钮。

若要在应用 Checkerboard 效果时保留图层透明度,请在工具选项面板中点按效果名称,然后选取保留透明度。

应用 Stripes 效果#

Stripes 效果会使用可自定的条纹图案填充所选图层。

自定效果:

  • 点按 颜色 1 颜色框,为一组条纹选择颜色。也可以按住键盘上的 Option ⌥ 键,快速从图像中拾取颜色。
  • 点按 颜色 2 颜色框,为另一组条纹选择颜色。也可以按住键盘上的 Option ⌥ 键,快速从图像中拾取颜色。
  • 移动 宽度 滑块以调整图案中条纹的宽度。也可以输入 0.0 px 到 800.0 px 之间的值。
  • 移动 锐度 滑块以调整条纹的锐利度。也可以输入 0% 到 100% 之间的值。
  • 移动 不透明度 滑块以调整图案透明度。点按 Opacity (Normal) 弹出式菜单,以选择不同的混合模式。
  • 移动效果绳索的控制柄以调整条纹位置。若未显示效果绳索,请点按工具选项面板中的绳索按钮。

若要在应用 Stripes 效果时保留图层透明度,请在工具选项面板中点按效果名称,然后选取保留透明度。

应用 Halo 效果#

Halo 效果会在所选图层上添加可自定的彩虹色光环。

自定效果:

  • 点按 颜色 颜色框以选择颜色;所选颜色会控制光环中红、绿、蓝各色所占的比例。选取纯红会使光环仅有红色,其他纯色亦然。纯白表示光环含有等量的红、绿、蓝。也可以按住键盘上的 Option ⌥ 键,快速从图像中拾取颜色。
  • 移动 光环半径 滑块以调整光环整体大小。也可以输入 0.0 px 到 1000.0 px 之间的值。
  • 移动 光环宽度 滑块以调整光环整体宽度。也可以输入 0.0 px 到 300.0 px 之间的值。
  • 移动 光环重叠 滑块以调整红、绿、蓝各光环彼此重叠的程度。也可以输入 0% 到 100% 之间的值。
  • 移动 条纹强度 滑块以调整光环中色彩强度。也可以输入 0% 到 300% 之间的值。
  • 移动 条纹对比度 滑块以调整光环中色彩对比度。也可以输入 0% 到 500% 之间的值。
  • 移动 时间 滑块以重新生成光环图案。也可以输入 0% 到 100% 之间的值。
  • 移动 不透明度 滑块以调整光环透明度。点按 Opacity (Normal) 弹出式菜单,以选择不同的混合模式。
  • 移动效果绳索的控制柄以调整光环位置。若未显示效果绳索,请点按工具选项面板中的绳索按钮。

若要在应用 Halo 效果时保留图层透明度,请在工具选项面板中点按效果名称,然后选取保留透明度。

应用 Star 效果#

Star 效果会在所选图层上生成类似超新星的星芒。

自定效果:

  • 点按 颜色 颜色框以为星芒外壳选择颜色。也可以按住键盘上的 Option ⌥ 键,快速从图像中拾取颜色。
  • 移动 半径 滑块以调整星体整体大小。也可以输入 0.0 px 到 300.0 px 之间的值。
  • 移动 十字缩放 滑块以调整十字图案大小。也可以输入 0% 到 10000% 之间的值。
  • 移动 十字角度 转盘以调整十字图案角度。也可以输入 0.0º 到 359.9º 之间的值。
  • 移动 十字不透明度 滑块以调整十字图案透明度。也可以输入 -800% 到 0% 之间的值。
  • 移动 十字宽度 滑块以调整十字图案宽度。也可以输入 0% 到 300% 之间的值。
  • 移动 Epsilon 滑块以调整十字尖刺长度。也可以输入 -800% 到 0% 之间的值。
  • 移动 不透明度 滑块以调整效果透明度。点按 Opacity (Normal) 弹出式菜单,以选择不同的混合模式。
  • 移动效果绳索的控制柄以调整星体位置。若未显示效果绳索,请点按工具选项面板中的绳索按钮。

应用 Sunbeams 效果#

Sunbeams 效果会在所选图层上添加可自定的太阳。

自定效果:

  • 点按 颜色 颜色框以为太阳选择颜色。也可以按住键盘上的 Option ⌥ 键,快速从图像中拾取颜色。
  • 移动 太阳半径 滑块以调整太阳整体大小。也可以输入 0.0 px 到 800.0 px 之间的值。
  • 移动 最大条纹半径 滑块以调整阳光束大小。也可以输入 0% 到 1000% 之间的值。
  • 移动 条纹强度 滑块以调整阳光束强度。也可以输入 0% 到 300% 之间的值。
  • 移动 条纹对比度 滑块以调整阳光束对比度。也可以输入 0% 到 500% 之间的值。
  • 移动 时间 滑块以重新生成太阳图案。也可以输入 0% 到 100% 之间的值。
  • 移动 不透明度 滑块以调整太阳透明度。点按 Opacity (Normal) 弹出式菜单,以选择不同的混合模式。
  • 移动效果绳索的控制柄以调整太阳位置。若未显示效果绳索,请点按工具选项面板中的绳索按钮。

若要在应用 Sunbeams 效果时保留图层透明度,请在工具选项面板中点按效果名称,然后选取保留透明度。

应用 Clouds 效果#

Cloud 效果会在所选图层上生成柔和的云彩图案。

自定效果:

  • 点按 前景颜色 颜色框以为云彩最亮区域选择颜色。也可以按住键盘上的 Option ⌥ 键,快速从图像中拾取颜色。
  • 点按 背景颜色 颜色框以为云彩阴影区域选择颜色。也可以按住键盘上的 Option ⌥ 键,快速从图像中拾取颜色。
  • 移动 宽度 滑块以调整云彩图案大小。也可以输入 0% 到 1000% 之间的值。
  • 移动 不透明度 滑块以调整云彩图案透明度。点按 Opacity (Normal) 弹出式菜单,以选择不同的混合模式。

显示应用效果前后效果或重设效果#

显示原图:点按显示原图按钮,或按键盘上的 Control ⌃ + M,即可查看图像在未应用任何效果时的外观。

显示分屏比较:Option ⌥ – 点按显示原图按钮、按键盘上的 Control ⌃ + C,或用力点按画布。

若要重设所有效果,请点按工具选项面板底部的重设。