排列和组合形状

形状图层本质上与其他图层(图像和文字)一样,因此可以直接使用排列工具来移动或调整它们的大小。

每当在图像中绘制形状时,Pixelmator Pro 默认会将每个形状添加到独立图层。不过,形状有多种组合方式:一个形状可与另一个形状合并、相减、相交或排除,而不必各自在独立图层中。组合形状后,多个形状图层会变成由多个组件构成的单个形状。

请注意,组合形状时,所选选项会应用到其下方所有形状的组合。例如,添加两个形状后,可以从下方形状中减去顶部形状,但不能反过来。之后若添加另一形状,例如将它从组中下方两个形状排除,会先组合下方两个形状,再从其结果中排除顶部形状。

组合形状#

  1. 向图像添加两个或更多形状。
  2. 从屏幕顶部的工具菜单中选择一种矢量工具:钢笔、自由钢笔,或 工具 > 绘制 中的某个形状。
  3. 在图层边栏中,Command ⌘ – 点按以选择想组合的全部形状。
  4. 选择以下任一操作:

合并#

合并多个形状时,多个形状图层会合并成由多个组件构成的单个形状。合并后的形状外观相同,但可轻松作为一个整体移动;每个单独组件也可调整为与整体形状合并、相减、相交或排除。

  • 从屏幕顶部的格式菜单中选取 格式 > 形状 > 合并形状
  • Control ⌃ – 点按图层边栏中的形状,然后选取合并形状。
  • 点按工具选项面板中的合并按钮。

相减#

从一个形状减去另一个形状时,所选形状重叠的任何区域都会从下方形状中移除(被减去的形状也完全不可见)。例如,若添加一个矩形形状,并在其上方添加椭圆形,矩形形状中会移除一个椭圆区域。

  • 从屏幕顶部的格式菜单中选取 格式 > 形状 > 相减形状
  • Control ⌃ – 点按图层边栏中的形状,然后选取相减形状。
  • 点按工具选项面板中的相减按钮。

相交形状#

让一个形状与另一个形状相交时,只保留重叠区域,其他区域均会移除。例如,若有两个彼此相邻且重叠的椭圆形,相交形状后只会保留中间的重叠区域。

  • 从屏幕顶部的格式菜单中选取 格式 > 形状 > 相交形状
  • Control ⌃ – 点按图层边栏中的形状,然后选取相交形状。
  • 点按工具选项面板中的相交按钮。

排除形状#

从一个形状排除另一个形状时,重叠区域会移除,其他区域保留。例如,若有两个彼此相邻且重叠的椭圆形,排除形状后会移除中间的重叠区域。

  1. 向图像添加两个或更多形状。
  2. 选择一种矢量工具:钢笔、自由钢笔,或 工具 > 绘制 中的某个形状。
  3. 在图层边栏中,Command ⌘ – 点按以选择想编辑的全部形状。
  4. 通过以下任一方式操作:
    • 从屏幕顶部的格式菜单中选取 格式 > 形状 > 排除形状
    • Control ⌃ – 点按图层边栏中的形状,然后选取排除形状。
    • 点按工具选项面板中的排除按钮。

查看形状的组件#

点按图层边栏中形状旁的展开三角形。随后可点按选择每个组件、移动它,或调整它与下方组件组合的方式。

为更容易区分不同形状组件,也可以选择显示其轮廓。

显示或隐藏形状轮廓#

  • 选中形状工具或排列工具后,Control ⌃ – 点按形状,然后选取显示形状轮廓。
  • 从屏幕顶部的显示菜单中选取 显示 > 叠加层 > 形状轮廓

合并形状的组件#

若希望作为一条路径对形状进行高级编辑,而非逐一调整组件路径,合并形状组件会很有用。

通过以下任一方式合并形状组件:

  • 从屏幕顶部的格式菜单中选取 格式 > 形状 > 合并形状组件
  • Control ⌃ – 点按图层边栏中的形状,然后选取合并形状组件。