在 Pixelmator Pro 中选取和管理颜色
在 Pixelmator Pro 中,点按任意颜色井时出现的取色器,可让你快速为不同工具、色彩调整或效果选取颜色。借助取色器,你可以通过颜色方块或色相滑块快速选色、按特定 RGB 值选择颜色、从精美的调色板集中选色、存储自定颜色或颜色集合等。你也可以轻松访问“颜色”窗口。
工具、调整和效果中的取色器#
取色器顶部区域包含用于从图像中拾取颜色的吸管、用于选取自定颜色的颜色方块和色相滑块,以及用于输入特定颜色值的 HEX 和 RGB 色彩代码栏位。在“色板”区域中,你可以从现有调色板选择颜色,或重复使用最近选取的颜色。

如何使用取色器#
- 若要打开取色器,请点按 Pixelmator Pro 工具、调整或效果中的任意颜色井,或者点按工具栏中的取色器
。 - 请执行以下任一操作:
- 查找颜色的值: 点按吸管
,然后将指针悬停在颜色上方以查看其值。你在画布上从一种颜色移到另一种颜色时,颜色值会随之变化。若要选取颜色,只需点按它。 - 选取颜色: 你可以从可用调色板列表中选择颜色,也可以使用色相滑块和颜色栏位手动选取。取色器使用基于 HSB(色相、饱和度、明亮度)的色彩模型,因此通常先拖移色相滑块,再在上方颜色栏位中指定饱和度和明亮度。你也可以手动输入 HEX 或 RGB 值来选择特定颜色。
- 管理调色板: 点按 Color Palettes 弹出式菜单以浏览现有调色板,或者点按相邻的“更多”菜单
,以移除、重命名和添加新调色板。 - 存储颜色以便再次使用: 在颜色色板列表中,点按 Add
或“更多”
,并在出现的菜单中选取 Add Preset。这会将当前选中的颜色加入当前选中的调色板。你也可以将最近选取的颜色中的色板直接拖到颜色色板列表中。
- 查找颜色的值: 点按吸管
处理渐变时,点按任意色标即可打开取色器。
存储、重新定义或移除颜色色板#
颜色色板是构成调色板或颜色集合的单个颜色。
- 存储新颜色色板: 选好颜色后,在 Color Palettes 弹出式菜单中选取你想存储该颜色的调色板,然后点按 Add
,或点按“更多”
,并在出现的菜单中选取 Add Preset。 - 重新定义颜色色板: 如果想用当前选中的颜色替换已有颜色色板的颜色,可以重新定义它。按住
Control ⌃点按颜色色板,然后在出现的菜单中选取 Redefine。 - 移除颜色色板: 按住
Control ⌃点按颜色色板,然后在出现的菜单中选取 Remove。
创建、重命名或移除调色板#
- 点按 Color Palettes 弹出式菜单旁的“更多”
。 - 请执行以下任一操作:
- 创建调色板: 选取 New Collection,创建空白的新调色板。
- 重命名调色板: 选取 Rename,为你的颜色色板集合指定其他名称。
- 移除调色板: 选取 Remove,删除调色板。
在前景色和背景色之间切换#
前景色和背景色是在使用画笔、填充工具和填充效果时,Pixelmator Pro 会使用的两种主要颜色。默认情况下,前景色为黑色,背景色为白色。例如,使用画笔在图层上绘画或用前景色填充图层时,它会变成黑色;如果切换到次要颜色——背景色——则会改为使用白色。你可以将前景色和背景色更改为所需的任意颜色。
若要在前景色和背景色之间切换,请执行以下任一操作:
- 按键盘上的
X。 - 点按颜色井旁的切换箭头
。
若要将前景色和背景色还原为黑色和白色,请按键盘上的 D 键。
使用取色器工具#
取色器工具是独立工具,可提供更多在 Pixelmator Pro 中选取和管理颜色的选项。在取色器工具选项中,你可以设置 Pixelmator Pro 中所有取色器的取样方式及其显示的信息。
- 请通过以下任一方式选取取色器工具:
- 点按工具边栏中的取色器
工具。 - 从屏幕顶部的“工具”菜单中选取 Tools > Color Picker。
- 按键盘上的
I。
- 点按工具边栏中的取色器
- 自定工具:
- 调整取色器取样大小: “1 point sample”从图像中的单个像素选取颜色。你也可以选取“3 by 3 average”或“5 by 5 average”,读取相邻 3×3 或 5×5 像素区域的平均值。
- 选择取色器的颜色值: 在 Color Code 下,选取“RGB”以使用 RGB 代码显示颜色值,或选取“HEX”以使用适合网页的 HEX 代码。
- 显示颜色名称: 选择“Show closest color name”复选框,以显示最接近所取颜色值的颜色名称;取消选择则隐藏它。
- 在图像中的任意位置点按以选取颜色。
使用“颜色”窗口#
Pixelmator Pro 的“颜色”窗口可让你访问系统调色板,以及颜色轮、滑块和铅笔等所有 macOS 原生取色器。

“颜色”窗口有四个区域:顶部是不同的取色器(颜色轮、颜色滑块、调色板、图像调色板和铅笔);中间是当前取色器;左下方是显示当前选中颜色的大颜色色板;此外还有用于拾取颜色的吸管,以及用于选取或存储新颜色色板的一排方格。
- 请通过以下任一方式打开“颜色”窗口:
- 点按取色器弹出式窗口中的
。 - 从屏幕顶部的“显示”菜单中选取 View > Show Colors。
- 按键盘上的
Shift ⇧+Command ⌘+C。
- 点按取色器弹出式窗口中的
- 请执行以下任一操作:
- 为选中的文字、形状、色彩调整或效果选取颜色: 点按“颜色”窗口顶部的取色器标签页,然后选择颜色。你可以使用滑块或输入值来指定更精确的颜色。
- 拾取颜色: 点按吸管,然后点按电脑屏幕上的任意位置以选择颜色。
- 存储颜色以便再次使用: 在“颜色”窗口底部,将左侧较大的颜色色板拖到右侧的空颜色井。若要移除颜色,请将它拖到程序坞中的废纸篓。存储在颜色色板图库中的颜色可跨应用和重启继续访问。