按形状或颜色选择区域

在 Pixelmator Pro 中,可以根据形状和颜色轻松选择图像的一部分。无论是勾勒对象、选择颜色相近的区域,还是针对特定颜色范围,都能找到适合各项编辑任务的工具。

快速选择工具#

快速选择工具(Quick Selection tool)只需在图像元素或整个对象上绘制,即可轻松选中它们。智能选择算法会分析图像中对象的颜色和纹理,检测其边缘并创建精确选区。

  1. 通过以下任一方式选择快速选择工具:
    • 在工具边栏中点按快速选择 工具,或从成组工具中选择它。
    • 从屏幕顶部的“工具”菜单中选取 Tools > Quick Selection
    • 按键盘上的 Q
  2. 在工具选项面板中自定快速选择工具选项:
    • 画笔大小: 更改选择画笔的大小;画笔越大,选中的区域越大。
    • 采样所有图层: 选择此项可不只根据活动图层,而是根据整个可见图像创建选区。
    • 显示选区预览: 选择此项可在创建初始选区前显示预览。
  3. 在想选择的区域或对象上绘制。

选择图像中颜色相近的区域#

颜色选择(或魔棒)工具可根据颜色选择图像中的元素或整个区域。

  1. 通过以下任一方式选择颜色选择工具:
    • 在工具边栏中点按颜色选择 ,或从成组工具中选择它。
    • 从屏幕顶部的“工具”菜单中选取 Tools > Select > Color Selection
    • 按键盘上的 W
  2. 在工具选项面板中自定颜色选择工具选项:
    • 采样所有图层: 选择此项可不只根据活动图层,而是根据整个可见图像创建选区。
    • 平滑边缘: 选择此项可自然平滑选区轮廓。
  3. 在图像中拖移以创建选区。

选择颜色范围#

选择颜色范围工具可选择图像中不连续、颜色相近的区域。

  1. 从屏幕顶部的“编辑”菜单中选取 Edit > Select Color Range
  2. 在工具选项面板中自定选择颜色范围工具选项:
    1. 采样所有图层: 打开 Sample All Layers 后,选择颜色范围工具会考虑图像中每个图层的内容,而非只考虑所选图层。
    2. 平滑边缘: 选择 Smooth Edges 可自然平滑选择颜色范围工具的轮廓。未选择 Smooth Edges 时,选区轮廓会更精确但带锯齿。
  3. 点按画布以拾取颜色范围,或点按工具选项面板中的颜色井以选择特定颜色。
  4. 拖移 Range 滑块,以调整会纳入选区的、接近所选颜色的其他颜色值数量。