Move, copy, and delete selected areas

Once you have made a selection, you can move, copy, delete, or cut the selected areas, apply effects or adjustments to them, create masks, crop images, and more.

Move a selected area#

  1. Choose the Arrange tool by doing one of the following:
    • Click the Arrange tool in the Tools sidebar.
    • Choose Tools > Arrange from the Tools menu at the top of your screen.
    • Press the V key on your keyboard.
  2. Move the pointer inside the selection and drag the selected area to a new position.

Copy or cut and paste a selected area#

  1. Make a selection of the area you want to copy.
  2. To copy the area, choose Edit > Copy or Edit > Cut.
  3. To paste the area, choose Edit > Paste.


You can cut, copy, and paste from Pixelmator Pro into other apps, or from other apps into Pixelmator Pro.

Copy or cut and paste a selected area as a new layer#

  1. Make a selection of the area you want to copy.
  2. With any selection tool active, Control ⌃ – click the image and choose Copy and Paste as Layer or Cut and Paste as Layer.

You can also press the Command ⌘ + J and Shift ⇧ + Command ⌘ + J keyboard shortcuts to copy or cut and paste selections as new layers.

Delete a selected area#

  1. Make a selection of the area you want to delete.
  2. Do one of the following:
    • Choose Edit > Delete.
    • Press the Delete key on your keyboard.
    • Press the Backspace ⌫ key on your keyboard.

Delete everything outside a selected area#

  1. Make a selection of the area you want to keep.
  2. Choose Edit > Invert Selection.
  3. Do one of the following:
    • Choose Edit > Delete.
    • Press the Delete key on your keyboard.
    • Press the Backspace ⌫ key on your keyboard.

Crop the image using a selection#

  1. Make a selection of the area you want to keep.
  2. Control ⌃ – click the image and choose Crop.
  3. Click Apply in the Tool Options pane to crop the image.